Recovering a “corrupt” project file?

Welcome Forums Forums Getting Help with Nvivo – Scroll to end to post a question Recovering a “corrupt” project file?

  • This topic is empty.
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #2617

    Hi Ben,

    I've just encountered the "your project file is corrupt" error message. Yes, the computer would have shut down while NVivo was running, although I have autosave on every 15 minutes, so I thought I was safe. There is a project file and a log file with the same modification date and time in the directory. I've tried copying the pair of them to a new location and doing "open project" from NVivo without success. What else can i do  now? i'm pretty unhappy as the only other backup I seem to have is from two weeks earlier, so a lot of work would have to be redone. BTW the project file is just about a half gigabyte, so not easy to send a copy by email or dropbox.

    Thanks,

    Alan Sloane

    University College Cork

    #2979

    Hi Ben,

    Panic over! I had made a change in the directory tree, moving the directory with my saved NVivo projects, into a slightly different place (up one level), and then opened the crashed project file from the new location (and subsequently, after reading some support suggestions, into a second new location). But this morning I thought to try putting everything back the way it had been at the time of the crash, and hallelujah it worked. So I've quickly made a copy of the project, saved everything and closed NVivo. All looks fine.

    Could you point me to – or outline here maybe – what is "best practice" for keeping backups in NVivo and for making sure that data losses are avoided (or at worst minimized)? For example, should I be exporting transcripts, memos, coding structures and the like to more stable file formats like RTF or TXT ? (I do all my transcription in NVivo, and that's really not work I'd want to have to do over). Am I asking for trouble having such a large project file (508Mb)? If so, what can I do about it – make my audio and photo sources external once I've transcibed and coded them?

    From my desperate web searches last night it seems that many people have had problems and lost work and time, so I'd likely not be the only one who'd find that useful.

    Thanks for the forum – knowing it was here let me sleep 🙂

    Alan.

    #2980

    Hi Alan,

    first thing to check, is that your project file is stored on the local computer and not somewhere on the network if you are working in a networked environment. . That is the optimum way to run NVivo and cuts down on several potential problems. The reason your file worked when you moved it back is because you copied an open project. Always close your project before copying it. NVivo creates a temporary 'log' file in the same folder when it is running. It closes this file when you close your project. When you 'crashed' this log file remained open so when you moved your project back into the correct folder, it was reunited with its log file so it could shut down correctly. 

     

    Have a look at this brief video on backing up:

    http://www.qdatraining.eu/content/tutorial-11-backing-your-nvivo-data-file

    Hope this helps but let me know if any of this is unclear.

    kind regards,

    #2981

    Ben, Thanks. I'll have a look at the video, sounds useful.

    Just for completeness you asked some questions above, so I'll answer them. No, I never have my project files on networked drives (nor on Flash or USB drives), always on the local hard drive of the computer where NVivo is running.

    Actually what I had done was – after the crash – copy both the project and the log file (in fact the directory where they both were located) away to another place on the disk. NVivo wouldn't open the project from that new location (error message about corruption etc.), but when I put both project and log file back to where they had been at the time of the crash (recreating the directory) then all worked fine. I assume somewhere in the project or log file there's a record of the actual pathnames in use.

    Thanks again for your (as always) quick response.

    Alan.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.